IBM Sterling Ideas

formerly Watson Supply Chain

Submit new product ideas for IBM Sterling solutions. Before you submit, please review existing ideas; if an idea close to yours already exists, it's better to add comments or vote on the existing idea. We will review your ideas and use them to help prioritize our product development. Best of all, the portal will automatically update you when the status of your idea has been changed. Order Management, Store Engagement, Watson Order Optimizer, Inventory Visibility, CPQ and Call Center are now part of Watson Supply Chain

Connect with IBM experts and your peers on the Supply Chain Collaboration Community and the Order Management Interest Group

Support for latest Cybersource SDK

The latest Cybersource SDK jar file (6.2.7) requires the use of apache commons lang 3 version 3.4 jar file (version 3.3 also works).

Since the base product already includes apache commons lang 3 version 3.2 however, the updated jar file does not get used.  This leads to exceptions when trying to execute Cybersource functionality in the most recent Cybersource SDK jar.

This is a critical issue since the Cybersource SDK version that is compatible with the commons lang 3 version 3.2 jar file is from August 2016 and is recommended by Cybersource to no longer be used due to security concerns.

  • Avatar32.5fb70cce7410889e661286fd7f1897de Guest
  • Jan 3 2020
  • Needs review
How will this idea be used?

This will allow us to upgrade to the latest Cybersource SDK version as required by Cybersource.

What is your industry? Retail
What is the idea priority? Urgent
DeveloperWorks ID
RTC ID
Link to original RFE
  • Attach files
  • Avatar40.8f183f721a2c86cd98fddbbe6dc46ec9
    Guest commented
    3 Jan 05:06pm

    We should have above option to use latest version of open source with understanding that validation will be performed by customer